Router Cisco 837 e Alice DSL PPPoE

Giusto per non dimenticarmene in futuro,  metto qui la configurazione che ho impostato sul router Cisco 837, connesso a una ADSL Alice 10 MBIT in PPoE, ma io qui mi ci aggancio a poco più di 4 MBIT qualunque router utilizzi, che distribuisce indirizzi IP sulla lan domestica via DHCP.

Non è farina del mio sacco: ho cercato un po’ di guide e documenti Cisco, ho fatto un po’ di prove e in un paio di ore era su tutto. Giusto per capire come funziona la configurazione di base di un Cisco, con cui non avevo mai giocato più di tanto. Ci sono alcuni aspetti che devo approfondire e qualcosa ancora con cui giocare, comunque ecco qui.

WhiteRabbit#sh conf
Using 2004 out of 131072 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WhiteRabbit
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XawK$o2mlq9XWy97gqB876jQvr1
!
no aaa new-model
ip subnet-zero
no ip source-route
!
ip dhcp pool HOME
 network 192.168.1.0 255.255.255.0
 domain-name CRISIS
 default-router 192.168.1.1
 dns-server 208.67.222.222 208.67.220.220
 lease 0 1
!
!
ip name-server 208.67.222.222
ip name-server 208.67.220.220
no ip bootp server
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
 description HOME LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 hold-queue 100 out
!
interface ATM0
 description ADSL INTERFACCIA ATM
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
 dialer pool-member 1
 protocol ppp dialer
 !
 dsl operating-mode auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Dialer0
 description CONNESSIONE ADSL ALICE 10MBIT
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp chap hostname alice
 ppp chap password 7 01120A0D580E
 ppp pap sent-username alice password 7 15130705072F
!
ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
!
control-plane
!
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
line vty 0 4
 password 7 14131C5C5A552C
 login
 transport preferred all
 transport input all
 transport output all
!
scheduler max-task-time 5000
!
end

4 Risposte a “Router Cisco 837 e Alice DSL PPPoE”

  1. Follow the white rabbit Neo…

  2. E’ una pessima idea quella di pubblicare la password di enable 🙂

    Dai un occhiata su qualche motore di ricerca e con poco sforzo troverai diversi metodi per tentare di crackarla (ed anche se non ti apparisse semplice lo è abbastanza ;-))

    Consiglio: cancella la riga.

    Ciao, f.

  3. E’ proprio per questo che l’ho modificata prima di postarla 😛

  4. Benissimo, a volte certe disattenzioni possono essere causa di fastidi 😉

    ciao, f.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.