“GNU GRUB version 1.97″beta 4 [ Minimal BASH-

Today I was updating an Ubuntu 9.04 virtual machine to 12.04. I went successfully to the 10.04 but after the 11.10 upgrade, at the reboot I had the following message:

“GNU GRUB version 1.97″beta 4 [ Minimal BASH-like line editing is supported.For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device/file completions]

sh:grub>

Awkward! Couple of Google queries and I ran into help.ubuntu.com, where I found this pretty nice solution:

ls
set prefix=(hd0,1)/boot/grub
set root=(hd0,1)
set
ls /boot
insmod /boot/grub/linux.mod
linux /vmlinuz root=/dev/sda1
initrd /initrd.img
boot

Give this commands on Grub command line and keep in mind that I’m using sda1 (sda=hd0 | partition=1) and both /root and /boot are on the same partition.

As the system boots, login and issue the following command as root:

grub-install /dev/sda
update-grub

Then reboot. The system should boot up fine now!

Be Sociable, Share!

Una Risposta a ““GNU GRUB version 1.97″beta 4 [ Minimal BASH-”

  1. I have this exact scenario! I really hope this will work for me too! Thanks for the post – given me some hope

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.